All Systems Operational
General Operational
UpCloud Control Panel Operational
API Operational
UpCloud Website Operational
AU-SYD1 - Australia Operational
AU-SYD1: Network Connections Operational
AU-SYD1: Virtualization Hosts Operational
AU-SYD1: Storage Backends Operational
AU-SYD1: Object Storage Operational
AU-SYD1: Managed Databases Operational
AU-SYD1: Managed Load Balancer Operational
AU-SYD1: Managed NAT Gateways Operational
AU-SYD1: Managed Kubernetes Operational
AU-SYD1: Other Operational
DE-FRA1 - Germany Operational
DE-FRA1: Network Connections Operational
DE-FRA1: Virtualization Hosts Operational
DE-FRA1: Storage Backends Operational
DE-FRA1: Object Storage Operational
DE-FRA1: Managed Databases Operational
DE-FRA1: Managed Load Balancer Operational
DE-FRA1: Managed Kubernetes Operational
DE-FRA1: Managed NAT Gateways Operational
DE-FRA1: Other Operational
ES-MAD1 - Spain Operational
ES-MAD1: Network Connections Operational
ES-MAD1: Virtualization Hosts Operational
ES-MAD1: Storage Backends Operational
ES-MAD1: Object Storage Operational
ES-MAD1: Managed Databases Operational
ES-MAD1: Managed Load Balancer Operational
ES-MAD1: Managed NAT Gateways Operational
ES-MAD1: Managed Kubernetes Operational
ES-MAD1: Other Operational
FI-HEL1 - Finland Operational
FI-HEL1: Network Connections Operational
FI-HEL1: Virtualization Hosts Operational
FI-HEL1: Storage Backends Operational
FI-HEL1: Managed Databases Operational
FI-HEL1: Managed Load Balancer Operational
FI-HEL1: Managed NAT Gateways Operational
FI-HEL1: Managed Kubernetes Operational
FI-HEL1: Other Operational
FI-HEL2 - Finland Operational
FI-HEL2: Network Connections Operational
FI-HEL2: Virtualization Hosts Operational
FI-HEL2: Storage Backends Operational
FI-HEL2: Object Storage Operational
FI-HEL2: Managed Databases Operational
FI-HEL2: Managed Load Balancer Operational
FI-HEL2: Managed Kubernetes Operational
FI-HEL2: Managed NAT Gateways Operational
FI-HEL2: Other Operational
FI-HEL2: Object Storage 2.0 Operational
NL-AMS1 - Netherlands Operational
NL-AMS1: Network Connections Operational
NL-AMS1: Virtualization Hosts Operational
NL-AMS1: Storage Backends Operational
NL-AMS1: Object Storage Operational
NL-AMS1: Managed Databases Operational
NL-AMS1: Managed Load Balancer Operational
NL-AMS1: Managed NAT Gateways Operational
NL-AMS1: Managed Kubernetes Operational
NL-AMS1: Other Operational
PL-WAW1 - Poland Operational
PL-WAW1: Network Connections Operational
PL-WAW1: Virtualization Hosts Operational
PL-WAW1: Storage Backends Operational
PL-WAW1: Object Storage Operational
PL-WAW1: Managed Databases Operational
PL-WAW1: Managed Load Balancer Operational
PL-WAW1: Managed NAT Gateways Operational
PL-WAW1: Managed Kubernetes Operational
PL-WAW1: Other Operational
SG-SIN1 - Singapore Operational
SG-SIN1: Network Connections Operational
SG-SIN1: Virtualization Hosts Operational
SG-SIN1: Storage Backends Operational
SG-SIN1: Object Storage Operational
SG-SIN1: Managed Databases Operational
SG-SIN1: Managed Load Balancer Operational
SG-SIN1: Managed Kubernetes Operational
SG-SIN1: Managed NAT Gateways Operational
SG-SIN1: Other Operational
UK-LON1 - United Kingdom Operational
UK-LON1: Network Connections Operational
UK-LON1: Virtualization Hosts Operational
UK-LON1: Storage Backends ? Operational
UK-LON1: Object Storage Operational
UK-LON1: Managed Databases Operational
UK-LON1: Managed Load Balancer Operational
UK-LON1: Managed Kubernetes Operational
UK-LON1: Managed NAT Gateways Operational
UK-LON1: Other Operational
US-CHI1 - USA Operational
US-CHI1: Network Connections Operational
US-CHI1: Virtualization Hosts Operational
US-CHI1: Storage Backends Operational
US-CHI1: Object Storage Operational
US-CHI1: Managed Databases Operational
US-CHI1: Managed Load Balancer Operational
US-CHI1: Managed NAT Gateways Operational
US-CHI1: Managed Kubernetes Operational
US-CHI1: Other Operational
US-NYC1 - USA Operational
US-NYC1: Network Connections Operational
US-NYC1: Virtualization Hosts Operational
US-NYC1: Storage Backends Operational
US-NYC1: Object Storage Operational
US-NYC1: Managed Databases Operational
US-NYC1: Managed Load Balancer Operational
US-NYC1: Managed NAT Gateways Operational
US-NYC1: Managed Kubernetes Operational
US-NYC1: Other Operational
US-SJO1 - USA Operational
US-SJO1: Network Connections Operational
US-SJO1: Virtualization Hosts Operational
US-SJO1: Storage Backends Operational
US-SJO1: Object Storage Operational
US-SJO1: Managed Databases Operational
US-SJO1: Managed Load Balancer Operational
US-SJO1: Managed NAT Gateways Operational
US-SJO1: Managed Kubernetes Operational
US-SJO1: Other Operational
SE-STO1 - Sweden Operational
SE-STO1 - Sweden Operational
SE-STO1: Managed Kubernetes Operational
SE-STO1: Network Connections Operational
SE-STO1: Virtualization Hosts Operational
SE-STO1: Storage Backends Operational
SE-STO1: Managed Databases Operational
SE-STO1: Managed Load Balancer Operational
SE-STO1: Managed NAT Gateways Operational
SE-STO1: Other Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
UpCloud API maintenance Apr 24, 2024 03:00-06:00 UTC
Update - Clarified that it is not possible to deploy new services during maintenance window
Apr 05, 2024 - 07:35 UTC
Scheduled - UpCloud API migration to a new cluster is scheduled for April 24th, 2024, from 03:00 to 06:00 UTC. This migration is being performed to enhance the maintainability, availability, and performance of our API in the future.

During this maintenance, api.upcloud.com will experience complete downtime, affecting access to the hub.upcloud.com control panel as well. View, deploy, modify, or delete actions for any resources will not be available during this period. However, existing resources will continue to function normally.

The complete downtime is estimated to last approximately 30-45 minutes, starting at 03:00 UTC. Additionally, there may be intermittent slow or failed requests during the maintenance window. We will make every effort to minimize the downtime and its impact.

If you have any questions, please contact UpCloud Support via email (support@upcloud.com).

Apr 04, 2024 - 15:25 UTC
[FI-HEL2]: Network maintenance Apr 25, 2024 19:00-23:00 UTC
Dear user,

We will be performing network maintenance in the FI-HEL2 datacenter between 25th of April 2024 19:00 - 23:00 UTC (22:00 - 02:00 EET). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Posted on Mar 12, 2024 - 09:38 UTC
[ES-MAD1]: Network maintenance May 2, 2024 20:00 - May 3, 2024 00:00 UTC
Dear user,

We will be performing network maintenance in the Madrid datacenter between 2nd of May 2024 20:00 - 00:00 UTC (22:00 - 02:00 CEST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Posted on Mar 12, 2024 - 09:40 UTC
[PL-WAW1]: Network maintenance May 6, 2024 20:00 - May 7, 2024 00:00 UTC
Dear user,

We will be performing network maintenance in the Warsaw datacenter between 6th of May 2024 20:00 - 00:00 UTC (22:00 - 02:00 CEST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Posted on Mar 12, 2024 - 09:42 UTC
[AU-SYD1]: Network maintenance May 7, 2024 12:00-16:00 UTC
Dear user,

We will be performing network maintenance in the Sydney datacenter between 7th of May 2024 12:00 - 16:00 UTC (22:00 - 02:00 AEST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Posted on Mar 12, 2024 - 09:44 UTC
[SE-STO1]: Network maintenance May 14, 2024 20:00 - May 15, 2024 00:00 UTC
Dear user,

We will be performing network maintenance in the Stockholm datacenter between 14th of May 2024 20:00 - 00:00 UTC (22:00 - 02:00 CEST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Posted on Mar 12, 2024 - 09:46 UTC
Past Incidents
Apr 18, 2024

No incidents reported today.

Apr 17, 2024
Completed - The scheduled maintenance has been completed.
Apr 17, 23:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 17, 19:00 UTC
Scheduled - Dear user,

We will be performing network maintenance in the FI-HEL1 datacenter between 17th of April 2024 19:00 - 23:00 UTC (22:00 - 02:00 EET). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Mar 12, 09:35 UTC
Resolved - Connectivity has been restored. If you are still experiencing issues reach out to our support at support@upcloud.com.
Apr 17, 22:57 UTC
Investigating - We are investigating connectivity issues to the UpCloud Hub and API.
Apr 17, 22:34 UTC
Apr 16, 2024
Completed - The scheduled maintenance has been completed.
Apr 16, 00:00 UTC
Update - Scheduled Maintenance is still in progress. Public Internet disruptions are to be expected with intermittent times of connectivity. Estimated time is ~ 2 hours. 1630 hours PST
Apr 15, 23:30 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 15, 20:00 UTC
Scheduled - Dear user,

We will be performing network maintenance in the Frankfurt datacenter between 15th of April 2024 20:00 - 00:00 UTC (22:00 - 02:00 CEST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Mar 12, 09:31 UTC
Apr 15, 2024
Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024
Completed - The scheduled maintenance has been completed.
Apr 12, 00:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 11, 20:00 UTC
Scheduled - Dear user,

We will be performing network maintenance in the Amsterdam datacenter between 11th of April 2024 20:00 - 00:00 UTC (22:00 - 02:00 CEST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Mar 12, 09:26 UTC
Apr 11, 2024
Apr 10, 2024
Completed - The scheduled maintenance has been completed.
Apr 10, 18:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 10, 14:00 UTC
Scheduled - Dear user,

We will be performing network maintenance in the Singapore datacenter between 10th of April 2024 14:00 - 19:00 UTC (22:00 - 02:00 GMT+8). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Mar 12, 09:23 UTC
Apr 9, 2024
Completed - The scheduled maintenance has been completed.
Apr 9, 07:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 9, 03:00 UTC
Scheduled - Dear user,

We will be performing network maintenance in the London datacenter between 9th of April 2024 03:00 - 07:00 UTC (04:00 - 08:00 BST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Mar 12, 09:19 UTC
Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024
Completed - The scheduled maintenance has been completed.
Apr 5, 12:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 5, 08:00 UTC
Scheduled - Dear user,

We will be performing network maintenance in the San Jose datacenter between 5th of April 2024 08:00 - 12:00 UTC (03:00 - 07:00 CST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Mar 12, 09:14 UTC
Apr 4, 2024
Completed - The scheduled maintenance has been completed.
Apr 4, 10:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 4, 06:00 UTC
Scheduled - Dear user,

We will be performing network maintenance in the New York datacenter between 4th of April 2024 6:00 - 10:00 UTC (02:00 - 06:00 EST). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).

Mar 12, 09:08 UTC