Payment Issues - 3rd Party Service
Incident Report for UpCloud
Resolved
Payment gateway has resumed normal operations and credit card payments should now go through again.
Posted about 1 month ago. Jun 13, 2019 - 11:22 UTC
Identified
We are currently experiencing issues with our 3rd party payments system. Some users may be unable to add further credits to their account during this time.
Posted about 1 month ago. Jun 13, 2019 - 09:48 UTC