[FI-HEL1] Network issue
Incident Report for UpCloud
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 16, 2018 - 08:03 UTC
Monitoring
We have restored network connectivity to all affected cloud servers in the single subnet and we are monitoring the situation.

If you are still unable to connect to your server, please contact our support at support@upcloud.com.

We apologise for the incident.
Posted about 1 month ago. Apr 16, 2018 - 07:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Apr 16, 2018 - 07:01 UTC
Investigating
We are investigating a networking issue that is affecting some cloud servers in our Helsinki data centre.

We are working to restore connectivity and resolve the situation as soon as possible.
Posted about 1 month ago. Apr 16, 2018 - 06:50 UTC