Control Panel Login Issue
Incident Report for UpCloud
Resolved
We have found the issue and resolved it. Control Panel back to normal operation.
Posted about 1 month ago. Mar 17, 2019 - 09:06 UTC
Identified
The issue has been identified and a fix is currently being implemented.
Posted about 1 month ago. Mar 17, 2019 - 09:01 UTC
Update
We are continuing to investigate the issue on our control panel, please use our old control panel located - https://my.upcloud.com

If you have any issues, please reach out to support@upcloud.com
Posted about 1 month ago. Mar 17, 2019 - 08:22 UTC
Investigating
We are currently investigating the issue.
Posted about 1 month ago. Mar 17, 2019 - 08:13 UTC
This incident affected: UpCloud Control Panel.