[Control panel]: Issues with our payment gateway
Incident Report for UpCloud
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 13, 2018 - 07:35 UTC
Monitoring
Our payment gateway provider has resolved the issue and the processing of credit card verifications during registration, one time payments as well as automated payments should be working now.

We are still monitoring the situation to verify that no new problems occur.

If you are still having problems with payments, please contact our support at support@upcloud.com. We apologise for the incident.
Posted 7 months ago. Apr 13, 2018 - 06:53 UTC
Identified
Our payment gateway provider Braintree Payments is having issues and this may affect the processing of credit card verifications during registration, one time payments as well as automated payments. As the resolution is beyond our control at this moment, we can work with you, our customers to make sure your credit balances remain positive during this time.
Posted 7 months ago. Apr 13, 2018 - 05:15 UTC