Temporary Manual Debit/Credit Card Payment Issues
Incident Report for UpCloud
Resolved
This has now been resolved and payments are functional again. If you notice any further issues, please do reach out to our support team via the Hub or email.
Posted Oct 08, 2021 - 12:28 UTC
Investigating
We have noticed some issues when making manual payments with debit/credit cards. For now, we recommend using PayPal to make a payment if necessary. We will provide further updates as soon as they are available.
Posted Oct 08, 2021 - 11:38 UTC
This incident affected: UpCloud Control Panel.