Issue with the UpCloud Control Panel

Incident Report for UpCloud

Resolved

This incident has been resolved.
Posted 5 days ago. Apr 02, 2025 - 06:50 UTC

Update

We are continuing to monitor for any further issues.
Posted 5 days ago. Apr 02, 2025 - 05:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 5 days ago. Apr 02, 2025 - 05:07 UTC

Identified

We are currently experiencing issues with login access to the UpCloud Control Panel. We are investigating the issue further and will report back as soon as possible. Please note that no customer resources are affected by this issue.
Posted 5 days ago. Apr 02, 2025 - 05:01 UTC
This incident affected: UpCloud Control Panel.