While we are very close to completing the planned maintenance work, the process is taking slightly longer than initially estimated. To ensure the stability and quality of the service, we have decided to extend the maintenance window by approximately 1 hour. Customers may experience intermittent connectivity or brief periods of unavailability for cloud servers during this extended period.
We sincerely apologize for this unexpected delay and appreciate your continued patience. We are working diligently to finalize the remaining steps and restore full service as quickly as possible.
Posted Nov 05, 2025 - 04:48 UTC
In progress
Due to unforeseen circumstances we're having more than expected downtime for some cloud servers. Customers may experience connection issues and interruptions to server management during this time.
Posted Nov 04, 2025 - 21:32 UTC
Scheduled
We will be performing network maintenance to improve our data center network in FI-HEL1. The maintenance window will commence on November 4, 2025, at 7:00 PM UTC and will be completed by November 5, 2025, at 5:00 AM UTC.
For the duration of the main maintenance period, customers might experience brief interruptions to network connections and service management in the Helsinki #1 data center. There could be one or more short breaks to public and private networks (SDN private networks and Utility network) in both public cloud and private cloud environments. While no larger disruptions are anticipated, network connectivity issues may occur due to the nature of the maintenance work.
If you have any questions or concerns regarding this maintenance, please reach out to us via 24/7 live chat on the Control Panel or by email (support@upcloud.com).
Posted Nov 04, 2025 - 19:00 UTC
This scheduled maintenance affected: FI-HEL1 - Finland (FI-HEL1: Network Connections).