[SG-SIN1]: Managed Kubernetes Issue

Incident Report for UpCloud

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2026 - 08:20 UTC

Identified

We have identified the root cause of the issues affecting the Managed Kubernetes service in the SG-SIN1 region.

Our team is currently working on a resolution to address the issue.

We will provide further updates once the fix is applied.
Posted May 13, 2026 - 06:11 UTC

Investigating

We are currently investigating an issue affecting the Managed Kubernetes Service in our SG-SIN1 region.

Users may find that their clusters are stuck in a Pending state. Our team is currently investigating the issue to identify the root cause.

We will provide additional updates as more information becomes available. We apologise for any inconvenience this may cause.
Posted May 13, 2026 - 03:26 UTC
This incident affects: SG-SIN1 - Singapore (SG-SIN1: Managed Kubernetes).