If you have any questions about this, we have our 24/7 support team available via live chat in the control panel or via email at support@upcloud.com.
Posted May 22, 2025 - 19:24 UTC
Monitoring
The deployed fix has successfully resolved the issues affecting our Managed Load Balancer service. We will continue to closely monitor the service to ensure continued stability.
Posted May 22, 2025 - 18:24 UTC
Update
We've deployed a fix we believe has resolved the issues with our Managed Load Balancer service. We will continue to monitor the situation closely.
Posted May 22, 2025 - 17:22 UTC
Update
We are continuing to work on a fix for this issue. You may experience intermittent issues fetching load balancer details and timeouts accessing the Managed Load Balancer page from the Dashboard. Deployed Managed Load Balancers may have intermittent timeouts as we work on the underlying problem.
Posted May 22, 2025 - 17:00 UTC
Identified
We have identified an issue with our Managed Load Balancer service across all data centres. Our team is actively investigating the root cause and working on a resolution.
Posted May 22, 2025 - 15:44 UTC
This incident affected: FI-HEL1 - Finland (FI-HEL1: Managed Load Balancer), AU-SYD1 - Australia (AU-SYD1: Managed Load Balancer), DE-FRA1: Germany (DE-FRA1: Managed Load Balancer), ES-MAD1 - Spain (ES-MAD1: Managed Load Balancer), FI-HEL2 - Finland (FI-HEL2: Managed Load Balancer), NL-AMS1 - Netherlands (NL-AMS1: Managed Load Balancer), PL-WAW1 - Poland (PL-WAW1: Managed Load Balancer), SG-SIN1 - Singapore (SG-SIN1: Managed Load Balancer), UK-LON1 - United Kingdom (UK-LON1: Managed Load Balancer), US-CHI1 - USA (US-CHI1: Managed Load Balancer), US-NYC1 - USA (US-NYC1: Managed Load Balancer), US-SJO1 - USA (US-SJO1: Managed Load Balancer), and SE-STO1 - Sweden (SE-STO1: Managed Load Balancer).