Issue with Control Panel affecting server management
Incident Report for UpCloud
Resolved
The incident with control panel has been resolved.
Posted 3 months ago. Jan 20, 2019 - 08:36 UTC
Identified
We are currently experiencing issues with our Control Panel and this is affecting server and account related actions globally. For the time being the older version of control panel at https://my.upcloud.com remains operational as well as direct API access. We are investigating the issue further and will report back as soon as possible.
Posted 3 months ago. Jan 20, 2019 - 06:57 UTC
This incident affected: UpCloud Control Panel.