Issue with our Live chat to Support

Incident Report for UpCloud

Resolved

Our live chat has now returned to full functionality.

Thank you for your utmost patience.
Posted Oct 21, 2025 - 02:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 10:08 UTC

Update

Our support team is available via Email only at support@upcloud.com, our live chat remains inaccessible.

We thank you for your patience.
Posted Oct 20, 2025 - 09:14 UTC

Update

If you require urgent attention, please reach out to us via email at support@upcloud.com
Posted Oct 20, 2025 - 08:09 UTC

Identified

We are currently experiencing issues with our Live chat and emails. We are investigating the issue further and will report back as soon as possible.

We thank you for your patience.

All UpCloud Services remains fully functional.
Posted Oct 20, 2025 - 07:34 UTC
This incident affected: UpCloud Control Panel.