Issue with our control panel
Incident Report for UpCloud
Resolved
Payment issues have now been resolved and users are able to make payments via Debit/Credit Cards directly via the Hub again. We apologise for any inconvenience caused during this time and as always, our support are on hand 24/7 should you have any questions.
Posted Nov 18, 2021 - 14:57 UTC
Update
We’re anticipating a fix
Posted Nov 17, 2021 - 08:22 UTC
Identified
We are currently experiencing issues with Credit Card payments due to our 3rd party payment processor, we recommend using PayPal or try to make payment tomorrow. We are working to solve the issue at the moment and will report back as soon as possible.

You will find that you will come across issues only when you are making manual payment OR when you try to edit / add new automated payments.
Posted Nov 17, 2021 - 07:43 UTC
This incident affected: UpCloud Control Panel.