Please contact our support team via live chat or support@upcloud.com if you have any further questions regarding the incident.
Posted May 04, 2026 - 13:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 12:35 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 04, 2026 - 12:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 04, 2026 - 12:28 UTC
Identified
We have identified an issue causing slowness with new logins to our control panel at https://hub.upcloud.com/ And we are currently working on fully stabilising the situation.
This may also delay calls to our API, and dependent systems such as Terraform.
Please note that this issue does not affect your active cloud services.
If you experience any issues, please do not hesitate to contact our support team via email support@upcloud.com.
We apologise for the inconvenience.
Posted May 04, 2026 - 11:15 UTC
This incident affected: UpCloud Control Panel and API.