The Managed Kubernetes maintenance window scheduled for 1st July, 07:00 - 11:00 UTC, is cancelled.
We will be rescheduling this to a new date and will send out a new notification with the updated details soon.
We sincerely apologise for any inconvenience this may cause.
Posted Jun 23, 2026 - 12:27 UTC
Scheduled
We will be conducting maintenance on our Managed Kubernetes Service in our Amsterdam, Warsaw, Stockholm and New York data centres on July 1st between 07:00 UTC and 11:00 UTC.
This maintenance impacts dev-md and prod-md plans, and these clusters will experience some small downtime. High-availability (prod-md-ha) plans will not be affected.
If you have any questions or concerns regarding this maintenance, please reach out to us via our 24/7 live chat or by email at support@upcloud.com.
Posted Jun 23, 2026 - 10:08 UTC
This scheduled maintenance affects: NL-AMS1 - Netherlands (NL-AMS1: Managed Kubernetes), SE-STO1 - Sweden (SE-STO1: Managed Kubernetes), PL-WAW1 - Poland (PL-WAW1: Managed Kubernetes), and US-NYC1 - USA (US-NYC1: Managed Kubernetes).