Issue with our Support Live Chat
Incident Report for UpCloud
Resolved
This issue with our Support live chat is now resolved.
Posted Nov 05, 2024 - 07:37 UTC
Monitoring
We have implemented a fix to resolve the issue with our Support Live Chat. You should now be able to reach our Support via Live Chat, web form or email (support@upcloud.com)

We are monitoring the situation closely and will post an update as soon as we confirm the issue is fully resolved.
Posted Nov 05, 2024 - 06:36 UTC
Investigating
We have identified and are currently investigating an issue with our Support Live Chat.

Unfortunately, we are unable to receive any Support tickets submitted via Live Chat, web form or email (support@upcloud.com) during this time.

We apologize for the inconvenience and will share an update as soon as we have more information.
Posted Nov 05, 2024 - 05:48 UTC
This incident affected: UpCloud Control Panel.