Issue with our Support Live Chat
Incident Report for UpCloud
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 14:36 UTC
Monitoring
We are currently monitoring the situation with Support Live Chat.

You should now be able to reach out to us using our live chats on the UpCloud hub or via email at support@upcloud.com
Posted Feb 22, 2024 - 11:32 UTC
Investigating
We have identified and are currently investigating an issue with our Support Live Chat via Control Panel

Please feel free to reach us via email at support@upcloud.com should you experience any issues.
Posted Feb 22, 2024 - 08:30 UTC
This incident affected: UpCloud Control Panel.