[SG-SIN1]: Compute node issue

Incident Report for UpCloud

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 06:57 UTC

Update

Our team continues to be fully engaged and focused on finding a mitigation. To avoid unexpected complications during the recovery process, please refrain from attempting server management operations, including Start, Restart, Shut down, and Force Shutdown.

We apologize for the inconvenience and appreciate your patience as we continue working to address the situation. If you have any questions or concerns regarding your services, please reach out to our Support team via Live Chat or via email support@upcloud.com
Posted Apr 22, 2026 - 05:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 04:53 UTC

Identified

We have identified an issue with one of the compute nodes in our SG-SIN1 data centre. The problem may cause affected cloud servers to become slow or unresponsive.
We are working to bring all affected servers back online and resolve the situation as soon as possible.
Posted Apr 22, 2026 - 03:47 UTC
This incident affected: SG-SIN1 - Singapore (SG-SIN1: Cloud Servers).