[FI-HEL2]: Network maintenance
Scheduled for Jun 5, 19:00 - 23:00 UTC
Update
Dear user,

We wanted to inform you that in order to accommodate the UpCloud API & Control Panel maintenance, we have decided to postpone the FI-HEL2 network maintenance originally scheduled for 25th of April 2024. The new date for the maintenance will be 5th of June 2024. However, please note that all other details remain unchanged.

We apologize for any inconvenience this may cause, but we assure you that this change will allow us to provide you with the best possible service. The network maintenance will take place at our FI-HEL2 datacenter on 5th of June 2024 from 19:00 to 23:00 UTC.
Posted Apr 19, 2024 - 09:45 UTC
Scheduled
Dear user,

We will be performing network maintenance in the FI-HEL2 datacenter between 5th of June 2024 19:00 - 23:00 UTC (22:00 - 02:00 EET). The maintenance might cause slowness in network connectivity for several minutes but no other disruptions are expected.

If there are any questions, please contact UpCloud Support via chat or email (support@upcloud.com).
Posted Mar 12, 2024 - 09:38 UTC
This scheduled maintenance affects: FI-HEL2 - Finland (FI-HEL2: Network Connections).