Issue with TLS Certification

Incident Report for UpCloud

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 05:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2026 - 03:03 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 20, 2026 - 16:22 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 20, 2026 - 12:40 UTC

Identified

We have identified an issue on newly created Managed Object Storage, Managed Kubernetes and Managed Load Balancer instances.

This affects the creation and renewal of TLS/SSL certifications and is causing newly created instances to enter a pending state. We apologize for any inconvenience that this may cause and are working towards resolving the issue as soon as possible.
Posted Jan 20, 2026 - 12:40 UTC
This incident affected: DK-CPH1 - Denmark (DK-CPH1: Managed Load Balancer, DK-CPH1: Managed Kubernetes), NO-SVG1 - Norway (NO-SVG1: Managed Load Balancer, NO-SVG1: Managed Kubernetes), AU-SYD1 - Australia (AU-SYD1: Managed Load Balancer, AU-SYD1: Managed Kubernetes), DE-FRA1 - Germany (DE-FRA1: Managed Load Balancer, DE-FRA1: Managed Kubernetes), ES-MAD1 - Spain (ES-MAD1: Managed Load Balancer, ES-MAD1: Managed Kubernetes), FI-HEL1 - Finland (FI-HEL1: Managed Load Balancer, FI-HEL1: Managed Kubernetes), FI-HEL2 - Finland (FI-HEL2: Managed Load Balancer, FI-HEL2: Managed Kubernetes, EUROPE-1: Managed Object Storage), NL-AMS1 - Netherlands (NL-AMS1: Managed Load Balancer, NL-AMS1: Managed Kubernetes), PL-WAW1 - Poland (PL-WAW1: Managed Load Balancer, PL-WAW1: Managed Kubernetes), SG-SIN1 - Singapore (SG-SIN1: Managed Load Balancer, SG-SIN1: Managed Kubernetes, APAC-1: Managed Object Storage), UK-LON1 - United Kingdom (UK-LON1: Managed Load Balancer, UK-LON1: Managed Kubernetes), US-CHI1 - USA (US-CHI1: Managed Load Balancer, US-CHI1: Managed Kubernetes, US-1: Managed Object Storage), US-NYC1 - USA (US-NYC1: Managed Load Balancer, US-NYC1: Managed Kubernetes), US-SJO1 - USA (US-SJO1: Managed Load Balancer, US-SJO1: Managed Kubernetes), and SE-STO1 - Sweden (SE-STO1: Managed Load Balancer, SE-STO1: Managed Kubernetes, EUROPE-3: Managed Object Storage).