Issue with Control Panel and API affecting new server deployments and configurations
Incident Report for UpCloud
Resolved
The incident has now been resolved. We apologise for the inconvenience and the disruption with API / deployments in our FI-HEL1 data centre.

If you still experience issues with API / deployments in FI-HEL1, please contact us via live chat or email at support@upcloud.com
Posted Jan 09, 2024 - 09:29 UTC
Monitoring
We have implemented the fix to resolve the issue and will continue to monitor the affected components.
Posted Jan 09, 2024 - 08:17 UTC
Identified
Our team has identified the cause of the issue impacting the Control Panel and API and has implemented a fix. During this time, we are seeing connectivity to affected services recovering. Thank you for bearing with us and we will share more updates as soon as it becomes available.
Posted Jan 09, 2024 - 07:56 UTC
Investigating
We are currently experiencing issues with our Control Panel and API and this is affecting server-related actions for new deployments globally. We are investigating the issue further and will report back as soon as possible.
Posted Jan 09, 2024 - 07:22 UTC
This incident affected: UpCloud Control Panel and API.