We have restored storage access on all affected cloud servers to normal operating status and continue to monitor the situation. If your server is still not fully functional, please contact our support at support@upcloud.com. We apologise for the incident.
Posted Nov 10, 2024 - 00:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 09, 2024 - 20:36 UTC
Update
We have identified the cause and are working on it. We will provide further updates soon. If you have any questions don't hesitate to contact our support via email (support@upcloud.com or via live chat
Posted Nov 09, 2024 - 20:35 UTC
Update
We are continuing to investigate this issue.
Posted Nov 09, 2024 - 17:17 UTC
Investigating
We are investigating an issue with our Storage equipment in our US-SJO1 data centre.
Posted Nov 09, 2024 - 17:11 UTC
This incident affected: US-SJO1 - USA (US-SJO1: Storage Backends).