DNS Resolution Issues in FI-HEL1 and FI-HEL2

Incident Report for UpCloud

Resolved

We have resolved the DNS resolution issue that was causing increased response times. Impacting our control panel https://hub.upcloud.com/ and certain cloud services in the FI-HEL1 and FI-HEL2 data centres.

After monitoring our systems for a some time, we can confirm now the situation is stable.

We apologise for the inconvenience.

If you have any questions, please don't hesitate to contact us via email support@upcloud.com or via live chat https://hub.upcloud.com/.
Posted Jun 16, 2026 - 13:30 UTC

Monitoring

We have resolved the DNS resolution issue that was causing increased response times. Impacting our control panel https://hub.upcloud.com/ and certain cloud services in the FI-HEL1 and FI-HEL2 data centres.

All systems are now stable, and there should be no further visible impact. We are continuing to monitor performance closely while we investigate the root cause.

We apologise for the inconvenience.

If you have any questions, please don't hesitate to contact us via email support@upcloud.com or via live chat https://hub.upcloud.com/.
Posted Jun 16, 2026 - 10:18 UTC
This incident affected: General, FI-HEL1 - Finland (FI-HEL1: Other), and FI-HEL2 - Finland (FI-HEL2: Other).