While our scheduled maintenance window continues, our engineering team is actively investigating reports of partial outages affecting instances within the EUROPE-2 region.
Expected Impact During this time, users may experience the following:
HUB Dashboard: Timeouts when attempting to load the object viewer.
Instance Connections: Periodic 503 Service Unavailable errors when connecting directly to an instance.
We apologise for the disruption. We remain fully committed to resolving this issue as quickly as possible and will provide another update as soon as we have more information.
Posted Jul 23, 2026 - 10:36 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 23, 2026 - 07:00 UTC
Scheduled
We will be performing routine upgrades of our Object Storage infrastructure in Europe-2 (DE-FRA1).
No customer-visible outages are expected. During brief periods within the maintenance window, some read or write operations may experience slightly increased latency or require a retry.
If you have any questions, please contact our support team through live chat in the UpCloud Control Panel or by emailing support@upcloud.com."