This maintenance has been postponed. We will update with a new maintenance update when we have more information.
Posted Jul 13, 2026 - 12:39 UTC
Update
We will be performing scheduled Object Storage maintenance in our Europe-2 region on July 15, 2026, between 07:00 - 16:00 UTC.
During this maintenance, we do not expect any major downtime; however, short blips in Object Storage operations are to be expected.
If you have any questions or concerns regarding this window, please reach out to our support team via live chat in the UpCloud Control Panel or by emailing us at support@upcloud.com.
Posted Jul 10, 2026 - 07:26 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 08, 2026 - 06:52 UTC
Update
The Object Storage maintenance in our Europe-2 region has been postponed. We will provide the updated maintenance window directly via this announcement once it has been rescheduled
Posted Jul 08, 2026 - 06:48 UTC
Scheduled
We will be performing scheduled Object Storage maintenance in our Europe-2 region on July 8, 2026, between 07:00 - 16:00 UTC.
During this maintenance, we do not expect any major downtime; however, short blips in Object Storage operations are to be expected.
If you have any questions or concerns regarding this window, please reach out to our support team via live chat in the UpCloud Control Panel or by emailing us at support@upcloud.com.