[US-SJO1]: Managed Kubernetes (Deployment & Management)

Incident Report for UpCloud

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 13:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2025 - 11:34 UTC

Identified

We have identified the issue affecting cluster operations in the San Jose (us-sjo1) region and are working on a fix.
Posted Oct 07, 2025 - 09:06 UTC

Investigating

We are currently investigating an issue impacting Managed Kubernetes cluster creation and management operations in our US-SJO1 datacenter. During this time, users may experience errors provisioning new clusters, as well as making changes to existing clusters for both the cluster and its node groups. Applications and workloads on existing clusters are not impacted. We sincerely apologise for the inconvenience and will share an update as soon as we have more information.
Posted Oct 07, 2025 - 01:20 UTC
This incident affected: US-SJO1 - USA (US-SJO1: Managed Kubernetes).