If you have any questions about this, we have our 24/7 support team available via live chat in the control panel or via email support@upcloud.com.
Posted 1 month ago. Feb 06, 2025 - 00:35 UTC
Update
We are continuing to monitor for any further issues.
Posted 1 month ago. Feb 05, 2025 - 19:27 UTC
Monitoring
All affected cloud servers are now back online. We will continue to monitor the situation closely.
If you continue to experience problems, please contact our 24/7 support team for assistance via live chat or support@upcloud.com.
Posted 1 month ago. Feb 05, 2025 - 18:46 UTC
Update
We're nearing the end of restoring the remaining affected cloud servers. We expect all services to be fully restored within the next hour. We apologise for the continued disruption and will provide another update within the hour, or sooner if available.
If you have any questions about this, we have our 24/7 support team available via live chat in the control panel or via email support@upcloud.com.
Posted 1 month ago. Feb 05, 2025 - 17:05 UTC
Update
We're making progress in restoring the remaining affected cloud servers. We expect all cloud servers to be back online within the next hour. We apologise for the ongoing disruption and will provide another update in one hour or sooner.
If you have any questions about this, we have our 24/7 support team available via live chat in the control panel or via email support@upcloud.com.
Posted 1 month ago. Feb 05, 2025 - 16:00 UTC
Update
We have brought the majority of affected cloud servers back online. Unfortunately, we encountered some unforeseen challenge with the remaining cloud servers, but we are working to bring them online as quickly as possible. We apologise for the continued disruption. The next update will be in one hour.
If you have any questions for this, we have our 24 / 7 support team available via live chat in the control panel or via email support@upcloud.com.
Posted 1 month ago. Feb 05, 2025 - 15:05 UTC
Update
We are making progress bringing the affected cloud servers back online. The issue is contained, and we expect most cloud servers to be available within one to two hours. We apologize for any inconvenience caused. The next update will be in 60 minutes or earlier.
If you have any questions for this, we have our 24/7 support team available via live chat in the control panel or via email support@upcloud.com.
Posted 1 month ago. Feb 05, 2025 - 13:56 UTC
Update
We have identified the root cause of the issue affecting some compute hosts in our FI-HEL1 data center. Our team is actively working to bring the impacted cloud servers back online. We anticipate that most servers will be available within the next two hours, though we are aiming for a faster recovery. We will share another update at 14:00 UTC.
Posted 1 month ago. Feb 05, 2025 - 13:23 UTC
Identified
We have identified an issue with one of the compute nodes in our Helsinki 1 data centre. The problem may cause affected cloud servers to become slow or unresponsive. We are working to bring all affected servers back online and resolve the situation as soon as possible.
We will give another update in 30 minutes.
Posted 1 month ago. Feb 05, 2025 - 13:00 UTC
Investigating
We are investigating a compute node issue that is affecting some cloud servers in our Helsinki 1 data centre.
Posted 1 month ago. Feb 05, 2025 - 12:46 UTC
This incident affected: FI-HEL1 - Finland (FI-HEL1: Virtualization Hosts, FI-HEL1: Storage Backends).